Oracle Database not started via srvctl with error CRS-2674, ORA-01034 if you installed Grid infrastructure with different user

by Vazha Mantua 28. November 2011 15:59

if you try start database(version 11R2) with srvctl you should got error:

 

We got this case, when we created database with Database scripts in postDBCreation.sql

 

PRCR-1079 : Failed to start resource ora.test.db

CRS-5011: Check of resource "TEST" failed: details at "(:CLSN00007:)" in "/u0/app/grid/product/11.2.0/log/testmachine/agent/ohasd/oraagent_grid/oraagent_grid.log"

CRS-2674: Start of 'ora.test.db' on 'testmachine' failed

ORA-01034: ORACLE not available

ORA-27101: shared memory realm does not exist

Linux-x86_64 Error: 2: No such file or directory

Process ID: 0

Session ID: 0 Serial number: 0

 

Cause of this error is that grid agent is running with difference user. During the instance startup using srvctl, agent tries to modify the files under $ORACLE_HOME/dbs and $ORACLE_HOME/srvm/admin,

But Unfortunately Grid user doesn't have write permissions to these directories, startup could fail.

Workaround:

You can add permission to write on directories for Grid user with commands:

chmod 775 /u0/app/oracle/product/11.2.0/dbs

chmod 775 /u0/app/oracle/product/11.2.0/srvm/admin

Tags: , , ,

ORA-15027: active use of diskgroup precludes its dismount

by Vazha Mantua 24. November 2011 22:33

Good Day,

Today We discuss about Error:ORA-15027: active use of diskgroup precludes its dismount.This error occurred  we I tried to  drop disk group on ASM instance (version 11GR2).

Cause of this error is that ASM spfile is located on Diskgroup

Solution:

In that case you need to create a pfile from the spfile and then startup the ASM instance using the pfile.

1.Find location of AMS spfile with command SQL> show parameter spfile

2.Create pfile from spfile

3.Start ASM instance with pfile, for Example SQL> startup pfile=$ORACLE_HOME/dbs/init+ASM.ora

4.Drop Diskgroup

Good Luck!

Tags:

ORA-27029: skgfrtrv: sbtrestore returned error

by Vazha Mantua 16. November 2011 13:43

Good Day All,

Today We observe a main error, which appear when you are trying restore database to new location via Veritas Netbackup soft

Problem:

When you tried restore for example your controlfile from autobackup which is stored on types, you got a error

ORA-27029: skgfrtrv: sbtrestore returned error

 

 

Cause:

With NetBackup on UNIX one can restore a database to a client other than the one that originally performed the backup. Symantec refers to this process as an 'alternate client restore' while Informix refers to this same process as an 'imported restore.By default configuration there is some restrictions for restoring to new server.

Workaround:

1.Remove restrictions for alternate client restores for all clients

Create the following f file /usr/openv/netbackup/db/altnames/No.Restrictions on the master server

2.Restrict the restore to / from certain clients

Create the following file on the NetBackup master server: /usr/openv/netbackup/db/altnames/<target_client_name>
where "<target_client_name>" is the name of the client that will receive the restore. This will allow this client to restore images from any other client.

 

 

Tags: ,

Augmenting Indoor Spaces

by Roman Akopov 2. November 2011 18:59

Tags:

ORA-600 [qertbfetchbyrowid]

by Vazha Mantua 15. October 2011 22:43

Good Evening All,

 

We have updated on of our database from 10.2.0.2 to 10.2.0.4, after upgrading in 2 days in alert log we got internal error ORA-00600: internal error code, arguments: [qertbFetchByRowID], [], [], [], [], [], [], [] .

 

Cause of this error is index corruption

How can we resolve this problem?

Solution

1. Find appropriate trace file in udump for discover which SQL Statement is cause of problem.

2.In SQL statement find table which is cause of problem

3. with SQL plan of statement you can find appropriate index which is corrupted

4.Recreate index(not rebuild)!

 

After these 4 steps you problem will be resolved!

 

Good luck

Tags: ,

Demo, Kinect for Windows SDK by Arman Obosyan

by Roman Akopov 24. September 2011 12:58

Demo, Kinect for Windows SDK by Arman Obosyan

Tags:

One-time Password Application for Windows Phone 7 by Giorgi Alkhazishvili

by Roman Akopov 24. September 2011 03:02

One-time Password Application for Windows Phone 7 by Giorgi Alkhazishvili

Tags:

Windows Phone 7 Guide for Symbian Qt Application Developers

by Arman Obosyan 22. September 2011 21:10

 

Продолжая тему портирования програм с разных платформ на Windows Phone

If you have been developing Qt applications for Symbian^3, Symbian Anna, or Symbian Belle and are interested in building your applications for Windows Phone, this guide is for you.
The guide covers what you need to know to add Windows Phone development to your skill set, while leveraging what you have already learned while developing Symbian Qt applications.

    Chapter 1: Introducing Windows Phone Platform to Symbian^3 Qt Application Developers
    Chapter 2: Windows Phone Application Design Guidelines
    Chapter 3: Windows Phone Developer and Designer Tools
    Chapter 4: C# programming
    Chapter 5: Introducing Windows Phone Application Life Cycle
    Chapter 6: Porting Applications to Windows Phone
    Chapter 7: Windows Phone Example Applications
    Chapter 8: Using the API Mapping Tool

Use the Qt to Windows Phone API mapping tool to find your way around when you discover the Windows Phone platform

Windows Phone 7 Guide for Symbian Qt Application Developers

Download guide Windows Phone 7 Guide for Symbian Qt Application Developers

Tags:

Problem During Installation Patch Set 10.2.0.4, PL/SQL: ORA-00904: "OTHER_XML": invalid identifier

by Vazha Mantua 18. September 2011 14:49

Good Day All,

 

 

 

After applying Patch Set 10.2.0.4 on Oracle RDBMS we discover that one of component was not updated correctly.Please see below:

 

Component Status Version HH:MM:SS
Oracle Database Server INVALID 10.2.0.4.0 00:19:27
Oracle XDK VALID 10.2.0.4.0 00:00:00
Oracle Workspace Manager VALID 10.2.0.4.3 00:01:22
Oracle Expression Filter VALID 10.2.0.4.0 00:00:16

 

In Installation Log file we found error PL/SQL: ORA-00904: "OTHER_XML": invalid identifier, while compiling package dbms_sqlpa.

In this post we will provide us how can you fix this problem.It’s very simple:

SQL>sqlplus / as sysdba
SQL>drop table plan_table;
SQL>@?/rdbms/admin/utlxplan
SQL>@?/rdbms/admin/prvtspao.plb
SQL>@?/rdbms/admin/utlrp.sql

Tags: ,

Kernel Transaction Manager by Roman Akopov

by Roman Akopov 17. September 2011 17:55

Kernel Transaction Manager by Roman Akopov

Tags: , ,