Lync 2013 mobility check

by Giorgi Jambazishvili 8. January 2013 14:27

In lync server 2013 there is no need to install lync mobility separately, it is built in installation.

image

after installation front end server you need to check mobility service, in lync 2010 checking way was to browse ulr https://lyncdiscover.doamain/autodiscover/autodiscover.svc from external and https://lyncdiscoverinternal.domain/autodiscover/autodiscover.svc , after browsing url the file was downloaded named autodiscover.svc
image

also you did check Test-CsMcxP2PIM , if this two test was ok it was mean that mobility service was worked in good state. When i installed lync 2013 first and wanted to check mobility, I browse urls and  discovered that urls is not working, but when i test Test-CsMcxP2PIM everything was ok. Than i start troobleshoot why was not working urs: https://lyncdiscover.doamain/autodiscover/autodiscover.svc   and https://lyncdiscoverinternal.domain/autodiscover/autodiscover.svc .
i see that in Autodiscover folder there was not autodiscover.svc file and there was Global.asax file that was not in lync 2010

image

I try to reinstall lync web components but nothing….

To check service availability  browse from internal http://lyncdiscoverinternal.domain.com/autodiscover/autodiscover.svc/root/user
from external http://lyncdiscover.domain.com/autodiscover/autodiscover.svc/root/user (when you publish autodiscover via http)
i try to login from lync mobile form android with autodiscover settings and my client logged in.
try to Test-CsMcxP2PIM , if it is ok and you have right publishing rule in tmg you mobile clients will work with autodiscover settings.
It’s recommended to have difference addresses for internal web services and for external web services.
218391

Tags:

ORA-39002: invalid operation ORA-39070: Unable to open the log file

by Vaja Mantua 18. December 2012 14:30

Hello All,

 

Today we resolved problem with error

ORA-39002: invalid operation
ORA-39070: Unable to open the log file.
ORA-29283: invalid file operation
ORA-06512: at "SYS.UTL_FILE", line 536
ORA-29283: invalid file operation

This error we got when use ASM file system as directory. expdp can’t create log file on ASM disk storage.

For avoiding creating expdp log file on ASM use second directory with standard  file system

Solution :

create directory EXPDP_LOG as '/u0/app/oracle/logs'

and use expdp parameter LOGFILE=EXPDP_LOG :exp_dbh.log

SharePoint Community event

by Arman Obosyan 26. November 2012 18:57

 

 

Meet SharePoint experts (“Gods of SharePoint") at 29 November 19:00

Michael Noel

Michael Noel is an internationally recognized technology expert, bestselling author, and well known public speaker on a broad range of IT topics.  He has authored several major industry books that have been translated into over a dozen languages worldwide. Significant titles include SharePoint 2013 Unleashed, Exchange Server 2013 Unleashed, Windows Server 2012 Unleashed, SharePoint 2010 Unleashed, and many more.  Currently a partner at Convergent Computing (www.cco.com) in the San Francisco Bay Area, Michael's writings and extensive public speaking experience across all seven continents leverage his real-world expertise helping organizations realize business value from Information Technology infrastructure.

Joel Oleson

Joel was the first dedicated SharePoint Administrator ever. He's been working with SharePoint nearly 12 years and worked at Microsoft in both IT and the product teams including Architecting the first rollout of Microsoft's own global search, upgrading the intranet, deploying enterprise deployments of team sites and my sites. On the Microsoft SharePoint Product Team was Sr. Product Manager and managed the IT Pro Audience in the SharePoint 2007 release. Joel has travelled over 100 countries in his quest to connect the global SharePoint community.  He has spoken in hundreds of events flying nearly 1 million miles reaching all corners of the globe. He currently manages a large SharePoint team in Salt Lake City at The Church of Jesus Christ of Latter-day Saints.

Paul J. Swider

Paul J. Swider is the CTO of RealActivity (www.theactivityproject.com) an organization focused on improving collaboration, compliance and fiscal responsibility in healthcare. He has two decades of proven software and healthcare experience and is involved in many community and philanthropic efforts including a founding member of Sharing the Point, an international effort which offers free training opportunities in emerging markets. Paul is an accomplished technology entrepreneur straight from a barrier Island near Charleston, SC where he occasionally gets to chase the tides and winds as an avid boater and sailor.

Interested in this event? Join us at 29 November 19:00 at Pixel Business center, 9th flour,

For more information and registration, please send a confirmation email to armano@microsoft.com with the subject: SharePoint 2013 seminar. Registration is on a first-come first-served basis.

MAP

---

Tags:

Developers | IT Pro

EventID 31196 – LS Response Group Service

by giorgi jambazishvili 20. November 2012 17:10

if you have eventid 31196 every two minutes, collaboration platform has failed to provision the data… , lync server trying to query data on the AD domain controller. However, the service does not reach the DC, During this time DC is fully functional and in the event log turns up nothing to flashy.

 

To resolve this event simply restart “Lync Server Response Group” service.

Tags:

HSRP Multipe Group Optimization

by Besarion GIorgadze 14. November 2012 17:40

  ერთ ფიზიკურ ინტერფეისზე შეიძლება იყოს რამდენიმე sub-interface-ი და თითო sub-interface-ისთვის თითო HSRP-group. თითო HSRP-group-ა აკეთებს დამოუკიდებლად state maintenance. ამავდროულად ეს ყველა sub-interface-ი მიბმული არის ერთ ფიზიკურ ინტერფეისზე. თუ მოხდა გათიშვა მოხდება ფიზიკური ინტერფეისის გათიშვა რის შემთხვევაში ყველა sub-interface-იც გაითიშება, და ამასთან ერთად რათქამა უნდა ყველა HSRP ჯგუფიც გაითიშება. მაგრა ყველა HSRP ჯგუფი დამოიკიდებლად გააკეთებს ამას, რაც ერთი ან ორი HSRP-ი ჯგუფის შემთხვევში პრობლემა არ არის მაგრამ თუ გვაქვს ათეულობით HSRP ჯგუფები მაშინ შეიძლება როუტერის პროცესორზე დიდი დათვირთვა წამოვიდეს რამაც სხვა არასასიამოვნო პრობლემები შეიძლება შექმნას. ასევე ათეულობით HSRP ჯგუფის maintenance-ის გაცილებით რთულია ვიდრე ერთი ან ორი ჯგუფის შემთხვევაში. ესეთი შემთხვევის ოპტიმიზაციისთვის cisco-ს მარშუტიზაცორებზე ამის გაკეთება შეიძლება standby follow feature-ით. standby follow feature-ი იძლება საშუალებას ერთ ფიზკიური ინტერფეისზე არსებულ HSRP ჯგუფები, state maintenance-ს აკეთებდეს ერთი ჯგუფი და დანარჩენი ჯგუფები აკვირდებონენ ერთ-ერთ ჯგუფს რის მიხედვითაც მოხდებს დანარჩენი ჯგუფების state-ების ცვილება. იმისთვის რომ ეს ყველაფერი ვნახოთ გავაკეთოთ პატარა ლაბი სადაც შევამოწმებთ ამ ყველაფერს.

Topology

 

ნახაზე გვავქს 2 როუტერი R5 და R3-ი და სამი VLAN-ი. vlan-11-ი  გამოიყენებს VLAN-10-ს state-maintenance-ისთვის, ხოლო VLAN 12 იყოს ჩვულებირივად დამოიკიდებლები vlan-ი. ჩვენს შემთხვევში VLAN10 იქნება Master group-ი, ხოლო VLAN11-ი იქნება client/slave group-ი. VLAN10-ს  აუცილებლად უნდა ერქვას სახელი რომ client/slave ჯგუფების  მიბმა მოხდეს. client/slave ჯგუფი არ იღებს მონაწილეობას არანაირ state-ების ცვლილებაში, მხოლოდ პერიოდულად ანახლებს მხოლოდ virtual MAC addresses. რაც გაცილების ნახლებს რესურს მოითხოვს ვიდრე, election-ებში მონაწილების მიღება.

 

 

R5# show running-config

interface Ethernet0/1

no ip address

!

interface Ethernet0/1.10

encapsulation dot1Q 10

ip address 10.10.10.5 255.255.255.0                           

standby 10 ip 10.10.10.1

standby 10 priority 250

standby 10 preempt

standby 10 name GROUP10

!

interface Ethernet0/1.11

encapsulation dot1Q 11

ip address 10.10.11.5 255.255.255.0

standby 11 ip 10.10.11.1

standby 11 follow GROUP10

standby 11 priority 250

standby 11 preempt

standby 11 name GROUP11

!

interface Ethernet0/1.12

encapsulation dot1Q 12

ip address 10.10.12.5 255.255.255.0

standby 12 ip 10.10.12.1

standby 12 priority 250

standby 12 name GROUP12

 

 

R3# show running-config

interface Ethernet0/1

no ip address

!

interface Ethernet0/1.10

encapsulation dot1Q 10

ip address 10.10.10.3 255.255.255.0

standby 10 ip 10.10.10.1

standby 10 priority 200

standby 10 preempt

standby 10 name GROUP10

!

interface Ethernet0/1.11

encapsulation dot1Q 11

ip address 10.10.11.3 255.255.255.0

standby 11 ip 10.10.11.1

standby 11 follow GROUP10

standby 11 priority 200

standby 11 name GROUP11

!

interface Ethernet0/1.12

encapsulation dot1Q 12

ip address 10.10.12.3 255.255.255.0

standby 12 ip 10.10.12.1

standby 12 priority 200

standby 12 name GROUP12

 

იმისთვის რომ VLAN10 იყოს master ჯგუფში აუცილებლად უნდა ერქვას სახელი, როგორც ზემოთ ავღნიშნე. ჩვენს შემთხვევაში დავარქვათ GROUP10-ი . VLAN11-ს მივუთითე master ჯგუფის სახელი რომ მოხდეს მიბმა ,  client/slave ჯგუფის,  

 

 

R5#show standby brief 

                     P indicates configured to preempt.

                     |

Interface   Grp  Pri P State   Active          Standby         Virtual IP                                            

Et0/1.10    10   250 P Active  local           10.10.10.3      10.10.10.1

Et0/1.12    12   250   Standby 10.10.12.3      local           10.10.12.1

 

ამ output-ში ჩანს მხოლოდ vlan10 და vlan 12 , vlan11-ი იმიტომ არ ჩანს რომ client/slave-ია

 

R5#show standby ethernet 0/1.10

Ethernet0/1.10 - Group 10

  State is Active

    8 state changes, last state change 00:23:33

  Virtual IP address is 10.10.10.1

  Active virtual MAC address is 0000.0c07.ac0a

    Local virtual MAC address is 0000.0c07.ac0a (v1 default)

  Hello time 3 sec, hold time 10 sec

    Next hello sent in 2.192 secs

  Preemption enabled

  Active router is local

  Standby router is 10.10.10.3, priority 200 (expires in 9.712 sec)

  Priority 250 (configured 250)

  Group name is "GROUP10" (cfgd)

  Followed by groups:

    Et0/1.11 Grp 11 Active 10.10.11.1 0000.0c07.ac0b refresh 10 secs (expires in 4.960 sec)

 

 

 

R5#show standby ethernet 0/1.11

Ethernet0/1.11 - Group 11

  State is Active (following "GROUP10")

    8 state changes, last state change 00:00:16

  Virtual IP address is 10.10.11.1

  Active virtual MAC address is 0000.0c07.ac0b

    Local virtual MAC address is 0000.0c07.ac0b (v1 default)

  MAC refresh 10 secs (next refresh 0 secs)

  Preemption enabled

  Active router is local

  Standby router is unknown

  Priority 250 (configured 250)

  Group name is "GROUP11" (cfgd)

  Following "GROUP10"

show standby-ში ჩანს რომელის არის Master-ის და რომელის არის slave-ი secondary.

 

დებაგეში როგორც ხედავთ არ ჩანს VLAN11-ის, პაკეტები იმიტრომ რომ vlan 11-ი იყენებს vlan10-ს.

 

 

R5#debug standby packets

*Nov 12 16:27:30.051: HSRP: Et0/1.10 Interface adv out, Passive, active 0 passive 1

*Nov 12 16:27:31.331: HSRP: Et0/1.10 Grp 10 Hello  in  10.10.10.3 Active  pri 200 vIP 10.10.10.1

*Nov 12 16:27:31.331: HSRP: Et0/1.10 Interface adv out, Active, active 1 passive 1

*Nov 12 16:27:31.331: HSRP: Et0/1.10 Grp 10 Coup   out 10.10.10.5 Listen  pri 250 vIP 10.10.10.1

*Nov 12 16:27:31.331: %HSRP-5-STATECHANGE: Ethernet0/1.10 Grp 10 state Listen -> Active

*Nov 12 16:27:31.331: HSRP: Et0/1.10 Interface adv out, Active, active 1 passive 0

*Nov 12 16:27:31.331: HSRP: Et0/1.10 Grp 10 Hello  out 10.10.10.5 Active  pri 250 vIP 10.10.10.1

*Nov 12 16:27:31.339: HSRP: Et0/1.10 Interface adv in, Passive, active 0, passive 1, from 10.10.10.3

*Nov 12 16:27:31.339: HSRP: Et0/1.10 Grp 10 Hello  in  10.10.10.3 Speak   pri 200 vIP 10.10.10.1

*Nov 12 16:27:31.691: HSRP: Et0/1.12 Grp 12 Hello  Received when interface down

*Nov 12 16:27:33.819: HSRP: Et0/1.10 Grp 10 Hello  in  10.10.10.3 Speak   pri 200 vIP 10.10.10.1

*Nov 12 16:27:34.095: HSRP: Et0/1.12 Grp 12 Hello  Received when interface down

*Nov 12 16:27:34.243: HSRP: Et0/1.10 Grp 10 Hello  out 10.10.10.5 Active  pri 250 vIP 10.10.10.1

 

Tags: , ,

Labs | HSRP

Congratulation

by Besarion GIorgadze 13. November 2012 12:20

მოგესალმებით, დღევანდელი დილა სასიამოვნო ამბავით დაიწყო, საქართველოში კიდევ ერთი CCIE R&S შემოგვემატა სანდრო ჩაჩანიძე,  (CCIE Number:37421) ვულოცავ და წარმათებებს ვუსურვებ.

Tags:

news

Cannot complete call forwarding

by Giorgi Jambazishvili 6. November 2012 14:08

I had the problem, when i wanted to forward calls to another person or number, there was error

cf

cf1

cf2

to solve this problem you must login lync control panel->voice Routing-> trunk configuration

open police that you have and disable refer support.

rs777

wait 5 or 10 minute when configuration replicated to everywhere and then try again to forward calls.

Tags:

IBGP redistribution to IGP

by Besarion GIorgadze 5. November 2012 15:52

მოგესალმებით, IBGP-იდან IGP-ში default-ად არ ხდება რედისტრიბუცია, იმისთვის რომ გაკეთდეს რედისტრიბუცია აუცილებელი არის BGP პროცესში კონკრეტულ address-family-ისთვის გავწეროთ შემდეგი ბრძანება bgp redistribute-internal

იმისთვის რომ ამ ყველაფერს უფრო ახლოდან შევხედოთ გავაკეთოთ მაგალითი: ავიღოთ 3 როუტერი R1, R3, R5. R1-ს და R3-ს შორის ავწიოთ IBGP და R3-და R5-ს შორის EIGRP-ი. როგორც არის მოყვანილი ნახაზე.


BGP Internal.jpg

კონფიგურაციის დეტალებზე არ დავიწყებ საუბარს, როგორც ზემოთ ავღნიშნე R1ს და R3-ს შორის არის IBGP AS13-ით ხოლოს, R3 და R5 შორის EIGRP AS35, R3 აკეთებს რედისტრიბუციას, EIGRP-ის და BGP-ის შორის. პირველადი კონფიგურაცია გავუშვათ bgp redistribute-internal-ის გარეშე.


R1#show running-config
!
interface Loopback0
ip address 1.1.1.1 255.255.255.0
!
interface Ethernet0/0
ip address 10.10.13.1 255.255.255.0
!
router bgp 13
no synchronization
bgp log-neighbor-changes
network 1.1.1.0 mask 255.255.255.0
neighbor 10.10.13.3 remote-as 13
no auto-summary

R3# show running-config
!
interface Ethernet0/0
ip address 10.10.13.3 255.255.255.0
!
interface Ethernet0/1
ip address 10.10.53.3 255.255.255.0
!
router eigrp 35
network 10.10.53.0 0.0.0.255
redistribute bgp 13 metric 1000 100 255 1 1500
no auto-summary
!
router bgp 13
no synchronization
bgp log-neighbor-changes
neighbor 10.10.13.1 remote-as 13
no auto-summary


R5#show running-config
!
interface Ethernet0/1
ip address 10.10.53.5 255.255.255.0
!
router eigrp 53
network 10.10.53.0 0.0.0.255
no auto-summary
end
!


კონფიგურაცია გაკეთებულია, გადავამოწმოთ neighboring-ი და ვნახოთ eigrp-ის topology table-ს

R3#show ip eigrp neighbors

EIGRP-IPv4 Neighbors for AS(35)

H Address Interface Hold Uptime SRTT RTO Q Seq

(sec) (ms) Cnt Num

0 10.10.53.5 Et0/1 14 20:41:00 21 200 0 5

R3#show ip bgp summary

BGP router identifier 155.1.23.3, local AS number 13

BGP table version is 2, main routing table version 2

1 network entries using 120 bytes of memory

1 path entries using 52 bytes of memory

1/1 BGP path/bestpath attribute entries using 124 bytes of memory

0 BGP route-map cache entries using 0 bytes of memory

0 BGP filter-list cache entries using 0 bytes of memory

BGP using 296 total bytes of memory

BGP activity 1/0 prefixes, 1/0 paths, scan interval 60 secs

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd   

10.10.13.1 4 13 1367 1370 2 0 0 20:41:02 1

R3#show ip eigrp topology

EIGRP-IPv4 Topology Table for AS(35)/ID(155.1.23.3)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,

r - reply Status, s - sia Status

P 10.10.53.0/24, 1 successors, FD is 281600

via Connected, Ethernet0/1

R3-ის ტოპოლოგიაში არ 1.1.1.0/24 ქსელი ეხლა დავამატოთ bgp redistribute-internal და შევამოწმოთ EIGRP-ის ტოპოლოგიის ცხრილი.

R3#show running-config | sec bgp

router bgp 13

no synchronization

bgp log-neighbor-changes

bgp redistribute-internal

neighbor 10.10.13.1 remote-as 13

no auto-summary

R3#show ip eigrp topology

EIGRP-IPv4 Topology Table for AS(53)/ID(155.1.23.3)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,   r - reply Status, s - sia Status

P 10.10.53.0/24, 1 successors, FD is 281600

via Connected, Ethernet0/1

P 1.1.1.0/24, 1 successors, FD is 2585600

via Redistributed (2585600/0)



bgp redistribute-internal-ის დამატების შემდეგ ვხედავთ რომ დაემატა 1.1.1.0/24 ქსელი. ეს იყო და ეს რაც შეეხებოდა IBGP-იდან IGP-ი რედ��სტრიბუციას.

Tags: ,

Labs | Routing

Deploy jboss application server on oracle enterprise manager

by Vaja Mantua 10. October 2012 10:57

Good Day,

Today we will observe how can we add jboss applications on OEM targets. Beginning with Grid Control OMS 10.2.0.3 and Grid Control Agent 10.2.0.3, the Third Party Plug-in for JBoss monitoring is available.

Supported version of jboss - JBoss are 4.0.x and above:  Supported version of OEM agent: 10.2.0.3 or higher, it will be perfect if you use version 11g

So what we did:

1. Install OEM agent 11g on target server , where is installed jboss service

2. Open  JNDI Port of JBoss Application Server on  the Agent Host. JNDI port is 1099

3.The Management ejb (MEJB) must have been deployed to JBoss Application Server, for this task you should find ejb-management.jar file under <JBoss_HOME>/docs/examples/jmx and  copy the jar file to the deploy folder of the running JBoss Application Server.

After this procedure go to EOM on Target Page<Middleware. and chose Jboss Apliication Server and fill following form:

jboss

 

You should fill server host,Install home and JNDI port(1099). After that you should add credential of server and OEM automatic find appropriate jboss service.

 

Most popular issue after deploying is metric error like this : Java Virtual Machine context could not be obtained. Cause of this issues is  memory parameters are not enough for resource usage.

Solution:

1.Stop OEM agent

2.Backup and edit agent11g/sysman/config/emd.properties file

3.Change from :
                           agentJavaDefines=-Doracle.dms.refresh.wait.time=1000 -DUrlTiming.UseJSSE=true-Dnetworkaddress.cache.ttl=1800 -Djava.awt.headless=true
                           to:
                           agentJavaDefines=-Xms256m -Xmx512m -Doracle.dms.refresh.wait.time=1000-DUrlTiming.UseJSSE=true -Dnetworkaddress.cache.ttl=1800-Djava.awt.headless=true

4. Start OEM agent

 

And Enjoy with OEM!

 

 

Server restored mcp.comunnity.ge

by Arman Obosyan 17. September 2012 00:43

We are back online!

server and data restored (always make backup! ;) )

 

 

 


Tags: