How Find Large Object in DB

by Vaja Mantua 8. November 2010 11:48
This is small script which provide how oracle developer can find large object in oracle DB for a schema.

script :

select round(sum(s),2),t
from (
select sum(b.bytes)/1024/1024/1024 s, a.table_name t from dba_indexes a, dba_segments b
where b.segment_type in ('INDEX','INDEX PARTITION')
and a.index_name=b.segment_name
and a.owner=&SCHEMA
group by a.table_name

union all

select sum(a.bytes)/1024/1024/1024 s,a.segment_name t from dba_segments a
where a.owner=&SCHEMA
and a.segment_type in ('TABLE','TABLE PARTITION')
group by a.segment_name

union all

select sum(b.bytes)/1024/1024/1024 s,a.table_name t from dba_lobs a, dba_segments b
where a.owner=&SCHEMA
and a.segment_name=b.segment_name
group by a.table_name

)
group by t
order by 1 desc

Tags: , ,

Run ADDM Statistic

by Vaja Mantua 8. November 2010 11:27

The Automatic Database Diagnostic Monitor (ADDM) analyzes data in the Automatic Workload Repository (AWR) to identify potential performance bottlenecks. For each of the identified issues it locates the root cause and provides recommendations for correcting the problem. An ADDM analysis task is performed and its findings and recommendations stored in the database every time an AWR snapshot is taken provided the STATISTICS_LEVEL parameter is set to TYPICAL or ALL. The ADDM analysis includes

Run ADDM report user can with Oracle Enterprise manager, but there i want tell you about script which provided same information. After running this script in PL/SQL Developer you can get ADDM report result.

1. Report Interval

you should decide on what period do you want see ADDM report, thats why you run this select on DB :

select * from dba_hist_snapshot
order by snap_id

and now you know begin and end snap_id(snap_id_1, snap_id_2)

2. Create ADDM Task

BEGIN
-- Create an ADDM task.
DBMS_ADVISOR.create_task (
advisor_name => 'ADDM', 
task_name => 'Test Report',
task_desc => 'Test Report');

-- Set the start and end snapshots.
DBMS_ADVISOR.set_task_parameter (
  task_name =>'Test Report',
parameter => 'START_SNAPSHOT',
  value => snap_id_1);

DBMS_ADVISOR.set_task_parameter (
  task_name => 'Test Report',
parameter => 'END_SNAPSHOT',
  value => snap_id_2);

-- Execute the task.
DBMS_ADVISOR.execute_task(task_name =>'Test Report');

END;

3. Get Report

SELECT DBMS_ADVISOR.get_task_report('Test Report ','TEXT', 'TYPICAL', 'ALL') AS report
FROM dual;

In BLOB you can see result of report

 

4. Delete Report

for deleting report you can run this statement:

BEGIN
  DBMS_ADVISOR.delete_task ( task_name => 'Test Report');
END;

Tags:

Personal

by Vaja Mantua 8. November 2010 11:25

Hello,

I am Vazha Mantua, Head of DBA team and Senior DB administrator at JSC Bank Of Georgia, on of the leading bank in Caucasus region. I am OCP 10g since 2009, I am married and have very nice daughter Smile

In my Blog i tell you all of administration oracle databases, i hope it will help you

Tags: , , , ,

MCP Club Tbilisi Seminars - Starting New Season

by David Ramishvili 20. October 2010 19:29

მოგესალმებით ყველას,


   ზაფხულმაც ჩაიარა და ყველას მოგვენატრა MCP კლუბი და საინტერესო სემინარები. ხანგრძლივი „დასვენების“  შემდეგ უკვე დროა შევუდგეთ ფიქრს, თუ როდის და  რა თემაზე ჩავატაროთ ახალი სემინარები. თემა რათქმაუნდა ბევრია, თუმცა არის ერთი საკითხი, შარშანდელი სემინარებიდან გამოიკვეთა მხოლოდ რამოდენიმე მომხსენებელი რომლებიც ძირითადად კითხულობენ სემინარებს ჩვენთვის. ვფიქრობთ რომ უკეთესი იქნება შედმეგი სემინარი ჩაატარონ მათ ვისაც ჯერ საერთოდ არ ჰქონია საშუალება რომ წარდგენილიყვნენ პუბლიკის წინაშე და გაეზიარებინათ თავის გამოცდილება ამა თუ იმ თემაზე.

მოკლედ ასე, მოგმართავთ სისტემურო ადმინისტრატორებო!
იყავით უფრო აქტიურები, გადახედეთ რა თემაზე ისურვებდით სემინარის წაკითხვას. მოგვწერეთ ელ-ფოსტაზე MCP-Club@hts.ge
, მოამზადეთ პრეზენტაცია და გაუზიარეთ თქვენი ცოდნა კოლეგებს. ჩვენ

ჩვენს მხრივ მაქსიმალურად გვერდში დავუდებით თქვენს ინიციატივას.


ჩათვალეთ რომ შემდეგი სემინარები დამოკიდებულია თქვენს აქტიურობაზე.

გისურვებთ წარმატებებს.

Tags:

Log Configuration on CLI with archive

by besarion giorgadze 20. October 2010 02:53

   Archive-ის საშუალებით შეგვიძლია შევინახოთ ყვ���ლა  ბრძანება რომელსაც შევასრულებთ ნებისმიერ კონფიგურაციის რეჟიმში თანმიმდევრობით. Archive-ი აკრეფილ ბრძანებეს ინახავს NVRAM-ში და შესაბამისად გადატვირთვის მერე იშლება. ასევე შეგვიძლია დავაგენერიროთ სტანდარტული syslog message-ი, შესაბამისად syslog message-ი შეგვიძლია შევინახოთ syslog-ის ლოკალურ ბუფერში ან syslog სერვერზე გადავაგდოთ. ეს feature-ის ძალიან მოსახერხებია მაშინ როცა რამდენიმე ადამიანს უწევს ერთი და იგივე მოწყბილობების კონფიგურაცია ან როცა გვიწევს კონფიგურაციის შეცვლა და გარკვეული პერიოდის შემდეგ გვინდა გადავამოწმოთ რა დავამატეთ რა წავშალეთ და ასე შემდეგ. მე პირადად ამას საკმაოდ აქტიურად ვიყენებ და ძალიან მიმარტივებს კონსოლში ცხოვრებას =)).

მაგლითად გვინდა რომელი მოწყობილობის კონფიგურაციის ცვლილებების ლოგირება.

archive
log config
  logging enable
 

logging enable – ჩავრთოთ კონფიგურაციის ლოგირება.

დამატებითი პარამეტრები

logging size <1-1000>  (Default 100) – მიუთითოთ ზომა . ანუ რამდენი ბრძანება დაიმახსოვროს.

hidekeys – არ გამოაჩინოს პაროლები (key-ები) ანუ როცა enable secret, OSPF key, ან რამე key-chain-ზე key-დავამატებთ ან  შევცვლით  პაროლს არ გამოაჩინოს კონფიგურაციის ლოგირებაში რა პაროლით იყო შეცვლილი ან დამატებული.

notify syslog – შეტყობინება გამოიტანოს syslog-ის სახით

ეხლა ვნახოთ ეს ყველაფერი როგორ გამოიყურება.

show archive log config all – ამ ბრძანების საშუალებით შეგვიძლია ვნახოთ რომელი მომხმარებლის სახელით და რომელ vty-ით იყო დაკონქტებული და რა  ბრძანებები იყო აკრეფილი და რა თანმიმდევრობით . თანმიმდევრობას განსაზღვრავს index-ები (idx).

sw1#show archive log config all
idx   sess           user@line      Logged command
    1     1       lab@vty0     |  logging enable
    2     1       lab@vty0     |  exit
    3     1       lab@vty0     |   exit
    4     1       lab@vty0     |interface GigabitEthernet0/2
    5     1       lab@vty0     | shutdown
    6     1       lab@vty0     | exit

ეხლა ცოტა ყურადღებას მივაქცევ hidekeys. მოდით მაგალიზე ვნახოთ.

რაც კონფიგურია არის თავის ნაჩვენები თავში გამოჩნება ჩვენს მიერ შეცვლილი პაროლი. default-ად hidekeys გამორთულია.

sw1#show archive log config all
idx   sess           user@line      Logged command
    1     1       lab@vty0     |  logging enable
    2     1       lab@vty0     |  exit
    3     1       lab@vty0     |   exit
    4     1       lab@vty0     |interface GigabitEthernet0/2
    5     1       lab@vty0     | shutdown
    6     1       lab@vty0     | exit
    7     2       lab@vty0     |enable secret test

და ესე იქნება როცა ჩართული არის hidekeys . ამ მაგალითში შეგვიძლია თვალნათლივ ვნახოთ რა განსხვავება. 

sw1#show archive log config all
idx   sess           user@line      Logged command
    1     1       lab@vty0     |  logging enable
    2     1       lab@vty0     |  exit
    3     1       lab@vty0     |   exit
    4     1       lab@vty0     |interface GigabitEthernet0/2
    5     1       lab@vty0     | shutdown
    6     1       lab@vty0     | exit
    7     2       lab@vty0     |enable secret test
    8     3       lab@vty0     |archive
    9     3       lab@vty0     | log config
   10     3       lab@vty0     |  hidekeys
   11     3       lab@vty0     |  exit
   12     3       lab@vty0     |   exit
   13     3       lab@vty0     |enable secret *****

sw1#show archive log config <0-2147483647> – კონკრეტულად მიუთითოთ  ნომრი (index-ი) და იმ ნომრიდან გვანახებს კონფიგურაციის ლოგირებას.

ესეც მაგალითი.

sw1#show archive log config 10
idx   sess           user@line      Logged command
   10     3       lab@vty0     |  hidekeys
   11     3       lab@vty0     |  exit
   12     3       lab@vty0     |   exit
   13     3       lab@vty0     |enable secret *****


sw1#show archive log config statistics – ეს ბრძანება გვიჩვენებს სტატისტიკას. რამდენი ლოგი დაგენერიდან რამდენ მეხსირებას იყენებს და ასე შემდეგ.

ეხლა რაც შეეხებე syslog notification-ს , როცა ჩავურთავთ notify syslog იწყებს syslog მესიჯების გენერაციას

Oct 20 02:35:39.308 tbilisi: %PARSER-5-CFGLOG_LOGGEDCMD: User:lab  logged command:interface GigabitEthernet0/1
Oct 20 02:35:45.692 tbilisi: %PARSER-5-CFGLOG_LOGGEDCMD: User:lab  logged command:no shutdown
Oct 20 02:35:47.093 tbilisi: %PARSER-5-CFGLOG_LOGGEDCMD: User:lab  logged command:exit

ესე გამოიყურება syslog მესიჯები რომლეიც იყო დაგენერირებული log confიგuration-ით . ამ ლოგებს თუ გვინდა შევინახავთ ლოკალურ ბუფერში ან syslog სერვერზე გადავაგზავნით.

 

 

Tags:

Tips & Tricks | Network Managment

Thanks MCP Club Tbilisi and HTS

by besarion giorgadze 15. October 2010 20:53

   მოგესალმებით, ამ პოსტით მინდა მადლობა გადაუხადო “MCP Club Tbilisi”-ს და “High-Tech Solutions”-ს იმ კეთილი და სასარგებლო საქმისთვის რასაც აკეთებენ ზოგადად და ამ კონკრეტულ შემთხვევაში ჩემი დახმარებისთვის. გამიკეთეს ჰოსტინგიდა ბლოგი conft.community.ge-ზე, მომცეს საშუალება ჩემი მწირედი გამოცდილება გამეზიარებინდა ქართველი ნეთვორკერებისთვის. ხოლო ახლახანს conft.ge-ს დომეინის რეგისტრაციაში და ამუშავებაში დამეხმარნენ. პრინციპი კი არდამეხმარენენ არამედ გამიკეთეს. გაიხარეთ, დიდი მადლობა გაწეული დახმარებისთვის!

Tags:

Cisco Automatic Backup Configuration

by Besarion GIorgadze 14. October 2010 20:18

    ხშირად არის სიტუაცია როდესაც კონფიგურაციის ავტომატური ბეკაპირება საკმაოდ საჭიროა და გვშველის გარკვეულ სიტუაციებში მაგ: rollback-ის დროს ან მეხი დაეცა რომელიღაც მოწყობილობას და პირველი გაფიქრება ნეტა ამის კონფიგი მქონოდაო  :D მაგრამ სად არის არც კონფიგი და არც მოწყობილობა აღარ არის ცოცხალია :D , როგორ და რანაირად გავაკეთოთ ეს ყველფერი მარტივად და ზედემტი თავის ტკივილის გარეშე. Archive კონფურუაციის რეჟიმიდან კეთდება ეს ყველაფერი. საჭიროა მხოლოდ TFTP  ან FTP  სერვერი, რომელზეც ჩაიწერება running-configuration-ი.

მაგალითად SW1-ის კონფიგურაცია გვინდა რომ ვაბექაფოთ tftp სერვერ-ზე ყოველ 10 წუთში

archive
path tftp://192.168.1.10/sw1/sw1-cfg
time-period 10
write-memory

Path 192.168.1.10 არიც tftp-სერვერის მისამართი, SW1 დირექტორია. სადაც გვინდა რომ ჩავწეროთ sw1-ის კონფიგურაციის ფაილები, sw1-cfg რა დაარქვას ფაილს, რომელიც ჩაიწერება TFTP-სერვერზე.

ამ შემთხვევაში ფაილები რომლებიც ჩაიწერება tftp server-ზე ექნება სახელები

sw1-cfg-1 , sw1-cfg-2 და ასე შემდეგ.

time-period    დრო რამდენ წუთში  მოიხსნას  backup-ი   დიაპაზონი არის <1-525600> ანუ 1 წუთიდან 1 წლამდე სურვილიდან გამომდინარე მიუთითოთ.

დამატებითი პარამეტრები

write-memory – როდესაც running-configuration-ს შევინახავთ startup-configuration-ში ნებრისმიერი ბრძანებით მაგ: wr ან copy run start – ამ დროსაც ავტომატრუად მოხდება running-configuration-ის გადაწერა tftp სერვერზე.

ყველამ ძალიან კარგად ვიცით რომ TFTP სერვერსა და FTP სერვერ შორის განსხვავება და ამ განსხვავებებზე აღარ დავიწყებ საუბარს archive გვაძლევს საშუალებას რომ კონფიგ ფაილები ვწეროთ ftp სერვერზეც. tftpსგან განსხვავებით ftp-ს შემთხვევაში უნდა დავუმატოთ ftp username და password რომ ftp სერვერზე გაიროს Cisco IOS-მა ავტორიზაცია რომ  FTP სერვერმა მისცეს ჩაწერის უფლება.  როგორ კედტება ეს ყველაფერი.

sw1(config)#ip ftp username conft
sw1(config)#ip ftp password conft.ge

show runn-ში ftp passowrd-ი გამოჩნდება TYPE 7-ით დაკრიპტული.

დანარჩენი რჩება ფაქტიურად იგივე tftp-ს მაგივრად იქნება ftp მეტი არაფერი განსხვავება არ არის.

archive
path ftp://192.168.1.125/sw1/sw1-cfg
time-period 5

sw1#archive config – ეს ბრძანება გვაძლევს საშუალებს იმ წუთასვე მოვხნათ კონფიგურაცია.

sw1#show archive
The next archive file will be named ftp://192.168.1.125/sw1/sw1-cfg-697
Archive #  Name
   0       ftp://192.168.1.125/sw1/sw1-cfg-690
   1       ftp://192.168.1.125/sw1/sw1-cfg-691
   2       ftp://192.168.1.125/sw1/sw1-cfg-692
   3       ftp://192.168.1.125/sw1/sw1-cfg-693
   4       ftp://192.168.1.125/sw1/sw1-cfg-694
   5       ftp://192.168.1.125/sw1/sw1-cfg-695
   6       ftp://192.168.1.125/sw1/sw1-cfg-696 <- Most Recent
   7       ftp://192.168.1.125/sw1/sw1-cfg-682
   8       ftp://192.168.1.125/sw1/sw1-cfg-683
   9       ftp://192.168.1.125/sw1/sw1-cfg-684
   10       ftp://192.168.1.125/sw1/sw1-cfg-685
   11       ftp://192.168.1.125/sw1/sw1-cfg-686
   12       ftp://192.168.1.125/sw1/sw1-cfg-687
   13       ftp://192.168.1.125/sw1/sw1-cfg-688
   14       fftp://192.168.1.125/sw1/sw1-cfg-689

ამ ბრძანებით შეგვიძლიან  ვნახოთ ბოლო კონფიგები რომლები მოიხნა ყველაზე ახალი რომელი არის და შემდგე კონფიგიის ფაილის  სახელი რა იქნება.

sw1#show archive config differences -  ამ ბრძანების საშუალებით შეგვიძლია შევადაროთ არსებული running-configuration ნებისმიე კონფიგურაციის ფაილს. ვნახოთ მაგალითზე.

sw1#show archive config differences ftp://192.168.1.125/sw1/sw1-cfg-696
Loading sw1/sw1-cfg-698 !!!
[OK - 15349/4096 bytes]

Contextual Config Diffs:
interface GigabitEthernet0/1
-shutdown

 

Tags:

Tips & Tricks | Network Managment

Inter VRF Routing with VRF Lite

by Besarion GIorgadze 11. October 2010 00:49

წინა პოსტში დავწერე და გავაკეთე  ლაბა VRF Lite-ზე და VRF Lite-ში Interior Routing პროტოკოლები. ბუნბრივია წინა პოსტიდან გამომდინარე იბადება შეკითხვა (მოსაზრება) როგორ შეიძლება რომ VRF-ებს შორის გავაკეთოდ Routing-ი ანუ ერთ VRF-ს დავანახოთ მეორე VRF-ი, როგორც იქნა მოვიცალე და გავაკეთე პატარა ლაბა.

inter-VRF Routing with vrf lite topology

ფიზიკური და ლოგიკური ტოპოლოგია

inter-VRF Routing with vrf lite addressing and color

ამ ნახაზე არის აღნიშნული თითეული VRF-ის IP მისამართები რომლებიც არის გამოყენებული და ფერი თითეული VRF-ისთვის. თქვენ კარგად ხედავთ რომ 172.16.1.0/30 ქსელი SW1-C1, SW1-C2, SW1-C3- შორის რომ მეორდება და ეს წინა პოსტში ამაზე ვისაუბრე მაგრამ არ გამიკეთბი ამიტომ გადავწყვიტე აქ გამეკეთებინა.

TASK-ი არის გავკეთო ისე რომ C1, C2 და C3 ხედავდენ Shared VRF-ის ქსელს მაგრამ ერმანეთის ქსელს ვერ ხედავხდენ. როგორც არის აღწერილი დიაგრამაზე.

inter-VRF Routing with vrf lite inter-vrf

პირველ რიგრში უნდა შევქმანთ VLAN-ები,  დავაკონფიკურიროთ ინტერფეიცები, VRF-ები და განვსაზღვროთ route distinguisher. route distinguisher განსაზღვის ორი ფორმატი არსeბობს <ASN>:<number> ან  <IP address>:<number>.  სადაც <number> ჩვეულებრივი ათობითი რიცვი. ეხლა გამოვიყენებ <ASN>:<number> ამ ფორმატს , მერე BGP-ი უნდა დავაკოფიგურიროთ Private AS ნომრით, რომლითაც მოვახდენთ VRF-ებს შორის მარშუტიზაციას. BGP-ს ავტონომური სისტემის ნომრად გამოვიყენოთ 65000

SW1

VRF-ების შექმნა

ip vrf c1
rd 65000:1
!
ip vrf c2
rd 65000:2
!
ip vrf c3
rd 65000:3
!
ip vrf shared
rd 65000:99
 

VlAN-ების შექმნა. Dynamips-ში მოგეხენებათ არის არის სვიჩი და ამიტომ სვიჩის მოდული ჩავაყენე როუტერი და Vlan database-იდან მომიწია vlan-ების შექმნა.


SW1#vlan database
SW1(vlan)#vlan 16
VLAN 16 modified:
SW1(vlan)#vlan 17
VLAN 17 modified:
SW1(vlan)#vlan 18
VLAN 18 modified:
SW1(vlan)#exit

ინტეფეისების IP მისამრთების კონფიგურაცია და VRF-ების განსაზღვრა

interface Loopback99
ip vrf forwarding shared
ip address 192.168.99.1 255.255.255.0
!
interface FastEthernet0/1
no switchport
ip vrf forwarding c1
ip address 172.16.1.2 255.255.255.252
!
interface FastEthernet0/3
no switchport
ip vrf forwarding c2
ip address 172.16.1.2 255.255.255.252
!
interface FastEthernet0/5
no switchport
ip vrf forwarding c3
ip address 172.16.1.2 255.255.255.252
!
interface FastEthernet0/13
switchport mode trunk
!
interface FastEthernet0/15
switchport mode trunk
!
interface Vlan16
ip vrf forwarding c1
ip address 172.16.0.1 255.255.255.0
!
interface Vlan17
ip vrf forwarding c2
ip address 172.17.0.1 255.255.255.0
!
interface Vlan18
ip vrf forwarding c3
ip address 172.18.0.1 255.255.255.0
!

აბა ვნახოთ რა გამოვიდა ხომ ყველაფერი სწორედ დავაკონფიგურირეთ

SW1#show ip vrf
  Name                             Default RD          Interfaces
  c1                               65000:1             Fa0/1
                                                       Vl16
  c2                               65000:2             Fa0/3
                                                       Vl17
  c3                               65000:3             Fa0/5
                                                       Vl18
  shared                           65000:99            Lo99

SW1#show ip vrf interfaces
Interface              IP-Address      VRF                              Protocol
Fa0/1                  172.16.1.2      c1                               up     
Vl16                   172.16.0.1      c1                               up     
Fa0/3                  172.16.1.2      c2                               up     
Vl17                   172.17.0.1      c2                               up     
Fa0/5                  172.16.1.2      c3                               up     
Vl18                   172.18.0.1      c3                               up     
Lo99                   192.168.99.1    shared                           up     

 

გადვიდეთ SW2-ს კონფიგურაციას. SW2-ზე გვჭირდება 2 VRF Customer 1 და Customer 2 და შესაბამისად ამ  Customer-ების Vlan-ები.

ip vrf c1
rd 65000:1
!        
ip vrf c2
rd 65000:2
!
!
!
sw2#vlan database
sw2(vlan)#vlan 16
VLAN 16 modified:
sw2(vlan)#vlan 17
VLAN 17 modified:
sw2(vlan)#vlan 216
VLAN 216 modified:
sw2(vlan)#vlan 217
VLAN 217 modified:
sw2(vlan)#exit
!
!

interface FastEthernet0/13
switchport mode trunk
!
interface Vlan16
ip vrf forwarding c1
ip address 172.16.0.2 255.255.255.0
!
interface Vlan17
ip vrf forwarding c2
ip address 172.17.0.2 255.255.255.0
!
interface Vlan216
ip vrf forwarding c1
ip address 172.16.2.1 255.255.255.0
!
interface Vlan217
ip vrf forwarding c2
ip address 172.16.17.1 255.255.255.0

SW3-  ზე გვჭირდება Customer 1 და Customer 3-ის Vlan-ები და VRF-ები

!
ip vrf c1
rd 65000:1
!        
ip vrf c3
rd 65000:3
!
sw3#vlan database
sw3(vlan)#vlan 16
VLAN 16 modified:
sw3(vlan)#vlan 18
VLAN 18 modified:
sw3(vlan)#vlan 316
VLAN 316 modified:
sw3(vlan)#vlan 318
VLAN 318 modified:
sw3(vlan)#exit
!
!
interface FastEthernet0/15
switchport mode trunk
!
interface Vlan16
ip vrf forwarding c1
ip address 172.16.0.3 255.255.255.0
!
interface Vlan18
ip vrf forwarding c3
ip address 172.18.0.3 255.255.255.0
!
interface Vlan316
ip vrf forwarding c1
ip address 172.16.3.1 255.255.255.0
!
interface Vlan318
ip vrf forwarding c3
ip address 172.18.3.1 255.255.255.0
!

ამის შემდეგ გადავივართ OSPF-ის კონგურაციაზე VRF-ებისთვის ყველა VRF-ისთვის უნდა აიწიოს ცალ ცალკე OSPF პროცესი. OSPF-ი გავაკეთოთ უმარტივესად მხოლოდ 1 არეა AREA0 (backbone Area). OSPF-ის Neighbor-ინგი იქნება შემდეგნაირი

inter-VRF Routing with vrf lite OSPF

SW1

ბრძანება network 0.0.0.0 255.255.255.255 ნიშნავს რომ როუტერმა ყველა ინტერფეიცმა მიიღოს OSPF-ში მონაწილეობა.

!
router ospf 1 vrf c1
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0
!
router ospf 2 vrf c2
log-adjacency-changes
  network 0.0.0.0 255.255.255.255 area 0
!
router ospf 3 vrf c3
log-adjacency-changes
  network 0.0.0.0 255.255.255.255 area 0
!

SW2

router ospf 1 vrf c1
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0
!
router ospf 2 vrf c2
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0

SW3

router ospf 1 vrf c1
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0
!
router ospf 3 vrf c3
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0

გადავამოწმოთ OSPF-ი

SW2

sw2#show ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
172.17.0.1        1   FULL/DR         00:00:34    172.17.0.1      Vlan17
172.16.1.2        1   FULL/DR         00:00:34    172.16.0.1      Vlan16
172.16.3.1        1   FULL/DROTHER    00:00:38    172.16.0.3      Vlan16

sw2#show ip route vrf c1

    172.16.0.0/16 is variably subnetted, 4 subnets, 2 masks
C       172.16.0.0/24 is directly connected, Vlan16
O       172.16.1.0/30 [110/2] via 172.16.0.1, 00:11:25, Vlan16
C       172.16.2.0/24 is directly connected, Vlan216
O       172.16.3.0/24 [110/2] via 172.16.0.3, 00:11:25, Vlan16

sw2#show ip route vrf c2

    172.17.0.0/24 is subnetted, 1 subnets
C       172.17.0.0 is directly connected, Vlan17
     172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C       172.16.17.0/24 is directly connected, Vlan217
O       172.16.1.0/30 [110/2] via 172.17.0.1, 01:45:17, Vlan17

SW3

sw3#show ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
172.18.0.1        1   FULL/DR         00:00:38    172.18.0.1      Vlan18
172.16.1.2        1   FULL/DR         00:00:38    172.16.0.1      Vlan16
172.16.2.1        1   FULL/BDR        00:00:33    172.16.0.2      Vlan16

sw3#show ip route vrf c1

  172.16.0.0/16 is variably subnetted, 4 subnets, 2 masks
C       172.16.0.0/24 is directly connected, Vlan16
O       172.16.1.0/30 [110/2] via 172.16.0.1, 00:13:37, Vlan16
O       172.16.2.0/24 [110/2] via 172.16.0.2, 00:13:37, Vlan16
C       172.16.3.0/24 is directly connected, Vlan316
O E1 192.168.99.0/24 [110/2] via 172.16.0.1, 00:13:37, Vlan16

sw3#show ip route vrf c3

     172.16.0.0/30 is subnetted, 1 subnets
O       172.16.1.0 [110/2] via 172.18.0.1, 00:13:28, Vlan18
     172.18.0.0/24 is subnetted, 2 subnets
C       172.18.3.0 is directly connected, Vlan318
C       172.18.0.0 is directly connected, Vlan18
O E2 192.168.99.0/24 [110/1] via 172.18.0.1, 00:13:28, Vlan18
sw3#

 

 

Multiprotocol BGP MP-BGP

MP-BGP ვიყენებთ მხოლოდ VRF-ებს შორის როუტინგისთვის. ამიტომ MP-BGP კონფიგურაცია საჭიროა მხოლოდ SW1-ზე. AS ნომრად გამოვიყენოთ 65000. BGP-ს კონფიგურაცია რომ დავიწყოთ BGP-ს აუცილებელია 1 IPმისამართი მაინც GLOBAL ROUTING Table-ში რომ მიანიჭოს Router-ID ამიტომ პირველ რიგში ვქმნით Loopback ინტერფეის

interface Loopback0
ip address 1.1.1.1 255.255.255.255

router bgp 65000
no synchronization
bgp log-neighbor-changes
no auto-summary
!
address-family ipv4 vrf shared
  redistribute connected
  no synchronization
exit-address-family
!
address-family ipv4 vrf c3
  redistribute connected
   no synchronization
exit-address-family
!
address-family ipv4 vrf c2
  redistribute connected
  no synchronization
exit-address-family
!
address-family ipv4 vrf c1
  redistribute connected
   no synchronization
exit-address-family

იმისთვის რომ შევამოწმოთ BGP-ს კონფიგურაცია თითეული address-family-სთვის

show ip bgp vpnv4 vrf <VRF Name>

ან ყველა address-family-ისთვის ერთდროულად

show ip bgp vpnv4 all

 

SW1#show ip bgp vpnv4 vrf c1

   Network          Next Hop            Metric LocPrf Weight Path
Route Distinguisher: 65000:1 (default for vrf c1)
*> 172.16.0.0/24    0.0.0.0                  0         32768 ?
*> 172.16.1.0/30    0.0.0.0                  0         32768 ?
*> 172.16.2.0/24    172.16.0.2               2         32768 ?

SW1#show ip bgp vpnv4 vrf c2

   Network          Next Hop            Metric LocPrf Weight Path
Route Distinguisher: 65000:2 (default for vrf c2)
*> 172.16.1.0/30    0.0.0.0                  0         32768 ?
*> 172.16.17.0/24   172.17.0.2               2         32768 ?
*> 172.17.0.0/24    0.0.0.0                  0         32768 ?

SW1#show ip bgp vpnv4 vrf c3

   Network          Next Hop            Metric LocPrf Weight Path
Route Distinguisher: 65000:3 (default for vrf c3)
*> 172.16.1.0/30    0.0.0.0                  0         32768 ?
*> 172.18.0.0/24    0.0.0.0                  0         32768 ?
*> 172.18.3.0/24    172.18.0.3               2         32768 ?

SW1#show ip bgp vpnv4 vrf shared

   Network          Next Hop            Metric LocPrf Weight Path
Route Distinguisher: 65000:99 (default for vrf shared)

*> 192.168.99.0     0.0.0.0                  0         32768 ?

მარშუტების იმპორტი და ექსპორტი

ეხლა უნდა დავაკონფიგურიროთ როუტების იმპორტი და ექსპორტი , რომელიც იძლევა საშუაბელბას VRF-ებს შორის გაიცვალოს ქსელები.

ყველა VRF-ის მარშუტი უნდა დავაექპორტოთ. მხოლოდ დავაიმპორტოთ shared VRF-ის მარშუტი.

!
!
ip vrf c1
rd 65000:1
route-target export 65000:1
route-target import 65000:99
!
ip vrf c2
rd 65000:2
route-target export 65000:2
route-target import 65000:99
!
ip vrf c3
rd 65000:3
route-target export 65000:3
route-target import 65000:99
!
ip vrf shared
rd 65000:99
route-target export 65000:99
route-target import 65000:1
route-target import 65000:2
route-target import 65000:3
!

 

ეხლა დავრჩა რედისტრიბუცია BGP-დან OSPF-ში და პირიქით

router ospf 1 vrf c1
log-adjacency-changes
redistribute bgp 65000 metric-type 1 subnets
network 0.0.0.0 255.255.255.255 area 0
!
router ospf 2 vrf c2
log-adjacency-changes
redistribute bgp 65000 metric-type 1 subnets
network 0.0.0.0 255.255.255.255 area 0
!
router ospf 3 vrf c3
log-adjacency-changes
redistribute bgp 65000 subnets
network 0.0.0.0 255.255.255.255 area 0
!
router bgp 65000
no synchronization
bgp log-neighbor-changes
no auto-summary
!
address-family ipv4 vrf shared
  redistribute connected
  no synchronization
exit-address-family
!
address-family ipv4 vrf c3
  redistribute connected
  redistribute ospf 3 vrf c3
  no synchronization
exit-address-family
!
address-family ipv4 vrf c2
  redistribute connected
  redistribute ospf 2 vrf c2
  no synchronization
exit-address-family
!
address-family ipv4 vrf c1
  redistribute connected
  redistribute ospf 1 vrf c1
  no synchronization
exit-address-family

ამის მერე შევამოწმოთ C1, C2 და C3-ის VRF-ები თუ გამოჩნდა Shared VRF-ის ქსელი 192.168.99.0/24 და Shared VRF-ში თუ გამოჩნდა სხვა VRF-ების ქსელები.

SW1#show ip route vrf c1

    172.16.0.0/16 is variably subnetted, 4 subnets, 2 masks
C       172.16.0.0/24 is directly connected, Vlan16
C       172.16.1.0/30 is directly connected, FastEthernet0/1
O       172.16.2.0/24 [110/2] via 172.16.0.2, 00:46:58, Vlan16
O       172.16.3.0/24 [110/2] via 172.16.0.3, 00:46:58, Vlan16
B    192.168.99.0/24 is directly connected, 02:20:36, Loopback99

SW1#show ip route vrf c2

     172.17.0.0/24 is subnetted, 1 subnets
C       172.17.0.0 is directly connected, Vlan17
     172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
O       172.16.17.0/24 [110/2] via 172.17.0.2, 02:20:30, Vlan17
C       172.16.1.0/30 is directly connected, FastEthernet0/3
B    192.168.99.0/24 is directly connected, 02:20:37, Loopback99

SW1#show ip route vrf c3

     172.16.0.0/30 is subnetted, 1 subnets
C       172.16.1.0 is directly connected, FastEthernet0/5
     172.18.0.0/24 is subnetted, 2 subnets
O       172.18.3.0 [110/2] via 172.18.0.3, 00:46:51, Vlan18
C       172.18.0.0 is directly connected, Vlan18
B    192.168.99.0/24 is directly connected, 02:20:39, Loopback99
SW1#show ip route vrf shared

     172.17.0.0/24 is subnetted, 1 subnets
B       172.17.0.0 is directly connected, 02:20:41, Vlan17
     172.16.0.0/16 is variably subnetted, 5 subnets, 2 masks
B       172.16.17.0/24 [20/2] via 172.17.0.2 (c2), 02:20:26, Vlan17
B       172.16.0.0/24 is directly connected, 02:20:41, Vlan16
B       172.16.1.0/30 is directly connected, 02:20:41, FastEthernet0/5

B       172.16.2.0/24 [20/2] via 172.16.0.2 (c1), 02:20:26, Vlan16
B       172.16.3.0/24 [20/2] via 172.16.0.3 (c1), 00:46:48, Vlan16
     172.18.0.0/24 is subnetted, 2 subnets
B       172.18.3.0 [20/2] via 172.18.0.3 (c3), 00:46:48, Vlan18
B       172.18.0.0 is directly connected, 02:20:42, Vlan18
C    192.168.99.0/24 is directly connected, Loopback99
SW1#

შემოწმების მერე ვხედავთ რომ C1, C2 , C3 აქვს Shared VRF-ის ქსელი და Shared-VRF-ს აქვს Customer-ების ქსელები. BGP-დან OSPF-ში რედისტრიბუციის შედეგად უნდა მიეღო SW2-ზე C1 , C2  მხოლოდ  SW3-ზე C1 და C3  Shared VRF-ის ქსელი

 

sw2#show ip route vrf c1

     172.16.0.0/16 is variably subnetted, 4 subnets, 2 masks
C       172.16.0.0/24 is directly connected, Vlan16
O       172.16.1.0/30 [110/2] via 172.16.0.1, 00:56:16, Vlan16
C       172.16.2.0/24 is directly connected, Vlan216
O       172.16.3.0/24 [110/2] via 172.16.0.3, 00:56:16, Vlan16
O E1 192.168.99.0/24 [110/2] via 172.16.0.1, 00:56:16, Vlan16

sw2#show ip route vrf c2

     172.17.0.0/24 is subnetted, 1 subnets
C       172.17.0.0 is directly connected, Vlan17
     172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C       172.16.17.0/24 is directly connected, Vlan217
O       172.16.1.0/30 [110/2] via 172.17.0.1, 02:30:09, Vlan17
O E1 192.168.99.0/24 [110/2] via 172.17.0.1, 02:30:06, Vlan17

sw3#show ip route vrf c1

    172.16.0.0/16 is variably subnetted, 4 subnets, 2 masks
C       172.16.0.0/24 is directly connected, Vlan16
O       172.16.1.0/30 [110/2] via 172.16.0.1, 00:57:41, Vlan16
O       172.16.2.0/24 [110/2] via 172.16.0.2, 00:57:41, Vlan16
C       172.16.3.0/24 is directly connected, Vlan316
O E1 192.168.99.0/24 [110/2] via 172.16.0.1, 00:57:41, Vlan16

sw3#show ip route vrf c3

     172.16.0.0/30 is subnetted, 1 subnets
O       172.16.1.0 [110/2] via 172.18.0.1, 00:57:32, Vlan18
     172.18.0.0/24 is subnetted, 2 subnets
C       172.18.3.0 is directly connected, Vlan318
C       172.18.0.0 is directly connected, Vlan18
O E2 192.168.99.0/24 [110/1] via 172.18.0.1, 00:57:32, Vlan18

ვხედავთ რომ ყველა VRF-ს აქვს Shared VRF-ის ქსელი ეხლა გავპინგოთ და ამით დავასრულოთ

sw2#ping vrf c1 ip 192.168.99.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.99.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/45/88 ms
sw2#ping vrf c2 ip 192.168.99.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.99.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/48/84 ms
sw2#

sw3#ping vrf c1 ip 192.168.99.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.99.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/48/140 ms
sw3#ping vrf c3 ip 192.168.99.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.99.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/54/148 ms
sw3#

ყველაფერი მუშაობს ესეც კონფიგ ფაილები და ტოპოლოგია Dynamips-ის

 

Tags:

Labs | Routing | VRF

VRF (virtual routing and forwarding) Lite and IGP over VRF Lite

by Besarion GIorgadze 27. September 2010 01:09

ცოტა ოდენს ვისაუბრებ სვიჩების და როუტერების ვირტუალიზაციაზე. VRF ეს არის ცალკე ინსტანსი routing table-ის და სხვასხვა სვიჩის თუ როუტერის სერვისების მაგალითად DHCP-ს. ანუ ერთ VRFს არანაირი კავშირი არ აქვს მეორესთან. ამავდროულად Global Routing table-იც რჩებ.ა სხვადასხვა VRF-ების IP მისამართების overlap-იც დასაშვებია. მაგალითად გვაქვს ორი VRFი C1  და C2 ორივემ შეიძლება გამოიყენოს ერთი და იგივე IP მისამართების pool-ი მაგალითად 192.168.1.0 და ყველანაირი პრობლემის გარეშე იმუშავებენ და ერთმანეთისგან საერთოდ იზოლირებულები იქნებიან.

ბევრ სიტუაციაში საკმადო მოსახერხებელია მაგრამ ეხლა ვისაუბრებ კონკრეტულ მაგალითზე , გვყავს ორი Customerი Customer 1  და Customer 2 და ზიან ორ სხვადასხვა შენობაში ისე უნდა გავაკეთოთ კავშირი რომ customer 1-ს არ ქონდეს კავშირი Customer2-დან და პირიქით

1) ყველა Customer-ს დაუდგათ თავისი მოწყობილობა.  ამას ის ნაკლი აქვს რომ ყვლა Customerს თავისი მოყობილობა ჭირდება და რაც მეტი იქნება Customer-ების  რაოდენობა მით უფრო გაძნელდება ქსელის მართვა და მანაჯმენტ და უაზროდ მოხდება ფინანსური რესურსების გამოყენება

VRF Lite With Eigrp

2) ყველა Customer-ი ACL-ების დონეზე ვფირტროთ და ისე ვატაროთ ტრაფიკი მაგრამ აქ თუ მოხდა IP მისამართების overlap-ი გვექნება უსიამოვნო სიტუაციები. და რაღაც მხივ ჩვენზე (მიმწოდებლებზე) იქნდება დამოკიდებული მათი ქსელის ინფრასტუქტურა. ყოველთვის ახალი Customerის დამატება ჩვენი თავის ტკივილი იქნებეა

VRF Lite With 11 

3) VRF-ის გამოყენებით სადაც ყველა Customer-ს ექნება თავისი ვირტუალი Routing Table-ი , რომელიც იქნება დამოუკიდებელი GLOBAL Routing Table-იდან და სხვა VRF-ებისთან

V1212RF Lite With 11

ეხლა განვიხილავ კონკრეტულ მაგალითს და პატარა ლაბორატორულს გავაკეთებ

VRF Lite With Eigrp

შევეცადე ნახაზი მაქიმალურად გასაგებად შემედგინა. vlan-ების შექმნაზე და IP მისამართების დადებაზე არ ვისაუბრებთ და dyanmipის ამ ლაბორატორიას დავდებ ბოლოს.

პირველ რიგში უნდა შევქმნათ VRF-ები  ორივე სვიჩზე

ip vrf c1
description VRF For Customer 1
!
ip vrf c2
description VRF For Customer 2

ამის მერე პორტებტს ვუთითებთ რომელ VRF-ში უნდა იყოს. ჩვენს შემთხევაში ორივე სვიჩზე Fa0/1  და Fa1/0.1 უნდა იყოს  C1-ში ხოლო Fa0/2 და Fa1/0.2 უნდა იყოს  C2-ში.

interface FastEthernet0/1
ip vrf forwarding c1

interface FastEthernet1/0.1
ip vrf forwarding c1
 

interface FastEthernet0/2
ip vrf forwarding c2

interface FastEthernet1/0.2
ip vrf forwarding c2
 

ამის მერე ვაკონფიგურებთ Interior gateway protocol-ს ამ ლაბორატორულში დავაკონფიგურირე EIGRP-ი ყველას სათითაოდ განვიხილავ დავიწყოთ Eigrp-ითი.

ROUTING EIGRP

  autonomous-system <number> – ASის ნომრები არ უნდა ემთხვეოდეს ერთმანეთს.

address-family ipv4 vrf <VRF NAME> – ამ ბრძალებით შევდივართ კონკრეტული კონკფიგურაციის რეჟიმში და აქ ვღწერთ იმ ქსელებს რომელიც გვინდა დაანონსდეს კონკრეტულ VRF-ში

SW1

router eigrp 10
auto-summary
!
address-family ipv4 vrf c2
  network 192.168.12.0
  network 192.168.212.0
  no auto-summary
  autonomous-system 11
exit-address-family
!
address-family ipv4 vrf c1
  network 192.168.11.0
  network 192.168.112.0
  no auto-summary
  autonomous-system 10
exit-address-family

SW2

router eigrp 10
auto-summary
!
address-family ipv4 vrf c2
  network 192.168.22.0
  network 192.168.212.0
  no auto-summary
  autonomous-system 11
exit-address-family
!
address-family ipv4 vrf c1
  network 192.168.21.0
  network 192.168.112.0
  no auto-summary
  autonomous-system 10
exit-address-family

რამდენიმე EIGRP-ს show ბრძანება

show ip eigrp vrf c1 neighbors – შევამოწოთ VRF C1 ის eigrp მეზობლები

show ip route vrf c1 – ვნახოთ VRF C1-ის routing Table-ი

ROUTING OSPF

SW1

router ospf 1 vrf c1
log-adjacency-changes
network 192.168.112.0 0.0.255.255 area 0
network 192.168.11.0 0.0.255.255 area 0

router ospf 2 vrf c2
log-adjacency-changes
network 192.168.212.0 0.0.255.255 area 0
network 192.168.12.0 0.0.255.255 area 0

SW2

router ospf 1 vrf c1
log-adjacency-changes
network 192.168.112.0 0.0.255.255 area 0
network 192.168.21.0 0.0.255.255 area 0

router ospf 2 vrf c2
log-adjacency-changes
network 192.168.212.0 0.0.255.255 area 0
network 192.168.22.0 0.0.255.255 area 0





sh ip ospf neighbor

sh ip route vrf *

Routing Static

SW1

ip route vrf c1 192.168.21.0 255.255.225.0 192.168.112.2
ip route vrf C2 192.168.22.0 255.255.255.0 192.168.212.2

SW2

ip route vrf c1 192.168.11.0 255.255.255.0 192.168.112.1
ip route vrf C2 192.168.12.0 255.255.255.0 192.168.212.1

Routing RIP

SW1

router rip
!
address-family ipv4 vrf c1
  network 192.168.112.0
  network 192.168.11.0
  no auto-summary
  version 2
exit-address-family
!
address-family ipv4 vrf c2
  network 192.168.212.0
  network 192.168.12.0
  no auto-summary
  version 2
exit-address-family

SW2

router rip
!
address-family ipv4 vrf c1
  network 192.168.112.0
  network 192.168.21.0
  no auto-summary
  version 2
exit-address-family
!
address-family ipv4 vrf c2
  network 192.168.212.0
  network 192.168.22.0
  no auto-summary
  version 2
exit-address-family

LAB Config files and Dynagen Network File

ესეც ფაილები . არქივი შეიცვალს ყველა მოწყობულობის კონფიგ ფაილს, Dynagen Network File-ს და ტოპოლოგიის გრაფიკული ფაილს

 

მემგონი ყველაფერი დავწერე რაც მინდოდა დამეწერა ამ პოსში იმედია მოგეწონებათ და გამოგადგებათ კიდევაც.

Tags: , ,

Labs | Routing | VRF

Donwload Cisco IOS From Rommon

by Besarion GIorgadze 25. September 2010 18:04

არც თუ ისე ხშირად არის ისეთი სიტუაციები როცა CISCO-ს როუტერი გვაკვდება ხელში ანუ IOS ზიანდება. ამ შემთხვევაში ყველაზე კარგი გამოსავალი არის უტილიტა tftpdnld. tftpdnld გვაძლევს საშუალებას Rommon-იდან ჩავწეროთ ახალი IOS.

ეხლა ეს ყველაფერი როგორც კეთდება ამისთვის გვჭირდება TFTP Server-ი მე ვიყენებ TFTPD და რაღათქმა უნდა  CISCO IOS-ი.

ვუშვებთ TFTP სერვერს და ვტვირთავთ როუტერს

შევდივართ rommon-ში. rommon-ში შესვლა ხდება ctrl+pause/Break –ღილაკებით

ამის შემდეგ ვაფორმატებთ მეხსიერებას

format flash: – ამ ბრანებით ხოლო ამის შემდგომ ხდება IP მისამართის და სხვა პარამეტრების მითითება

IP_ADDRESS=192.168.3.101

IP მისამართი 

 

IP_SUBNET_MASK=255.255.255.0

მასკა 

TFTP_SERVER=192.168.3.100

TFTP Server-ის მისამართი

 

DEFAULT_GATEWAY=192.168.3.1

Default Gateway

 

TFTP_FILE=c870-advsecurityk9-mz.124-20.T.bin

IOS-ის სახელი რომელიც უნდა გადმოვწეროთ

set

ამ ბრძანების საშულებით შეგვიძლია ვნახოთ რა პარამეტრები არის მითითებული

 

tftpdnld

რომელის დაიწყებს IOS გადმოწერას tftp სერვერიდან . რომ მორჩება გადმოწერას და ჩაწერეას ბოლოს

reset

 

გადაიტვირთება როუტერი და ჩიატვირთება ახალი IOSი

 

ესეც კიდევ მაგალითი: CISCO ISR 871 -ზე

 

Router#
Router#reload
Proceed with reload? [confirm]

*Apr 28 05:48:56.751: %SYS-5-RELOAD: Reload requested  by txapnia on console. Re                                                                             load Reason: Reload Command.
System Bootstrap, Version 12.3(8r)YI4, RELEASE SOFTWARE
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 2006 by cisco Systems, Inc.

C870 series (Board ID: 3-148) platform with 131072 Kbytes of main memory

rommon 1 > IP_ADDRESS=192.168.3.101
rommon 2 > IP_SUBNET_MASK=255.255.255.0
rommon 3 > TFTP_SERVER=192.168.3.100
rommon 4 > DEFAULT_GATEWAY=192.168.3.1
rommon 5 > TFTP_FILE=c870-advsecurityk9-mz.124-20.T.bin
rommon 6 > set
PS1=rommon ! >
TFTP_TIMEOUT=800000
FE_SPEED_MODE=4
TFTP_RETRY_COUNT=20
?=0
BOOT=
CRASHINFO=crashinfo_FAILED
BSI=0
RANDOM_NUM=717237572
ROM_PERSISTENT_UTC=1019972935
RET_2_RTS=
RET_2_RCALTS=
IP_ADDRESS=192.168.3.101
IP_SUBNET_MASK=255.255.255.0
TFTP_SERVER=192.168.3.100
DEFAULT_GATEWAY=192.168.3.1
TFTP_FILE=c870-advsecurityk9-mz.124-20.T.bin
rommon 7 > tftpdnld

          IP_ADDRESS: 192.168.3.101
      IP_SUBNET_MASK: 255.255.255.0
     DEFAULT_GATEWAY: 192.168.3.1
         TFTP_SERVER: 192.168.3.100
           TFTP_FILE: c870-advsecurityk9-mz.124-20.T.bin
Do you wish to continue? y/n:  [n]:  yes

Receiving c870-advsecurityk9-mz.124-20.T.bin from 192.168.3.100 !!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
File reception completed.
File flash:/c870-advsecurityk9-mz.124-20.T.bin already exists.
Deleting flash:/c870-advsecurityk9-mz.124-20.T.bin before creating new file with same name.
Delete operation will take approximately 28 to 700 seconds
Writing flash:/c870-advsecurityk9-mz.124-20.T.bin
Write operation will take approximately 112 to 336 seconds
Deleting flash:/c870-advsecurityk9-mz.124-20.T.bin before creating new file with same name.
Delete operation will take approximately 28 to 700 seconds

rommon 8 >
rommon 8 > reset
rommon 9 >

System Bootstrap, Version 12.3(8r)YI4, RELEASE SOFTWARE
Technical Support:
http://www.cisco.com/techsupport
Copyright (c) 2006 by cisco Systems, Inc.

C870 series (Board ID: 3-148) platform with 131072 Kbytes of main memory

Booting flash:/c870-advsecurityk9-mz.124-20.T.bin

Tags: , ,

Labs | Tips & Tricks